Wednesday, February 21, 2018

Cisco 4507 stuff

Find a mac address on a switch
show mac-address-table | include XXXX

XXXX= last 4 digits of the mac address of the device you re looking for.  I find that easiest, but you can search bigger range.  Cisco doesn’t use xx:xx:xx format
Cisco uses xxxx.xxxx.xxxx


Find summary of port
show int status | include xxxx


You can get additional detail about the port using
show running-config interface gigabitEthernet X/XX


Default the port configuration (from config)
default interface gigabitEthernet X/XX


NON 802.1X port config example

interface GigabitEthernet X/XX
description XXXXXXX
switchport access vlan XX
switchport mode access
switchport voice vlan 90
qos trust cos
auto qos voip trust
tx-queue 3
   bandwidth percent 33
   priority high
   shape percent 33
spanning-tree portfast
service-policy output autoqos-voip-policy
shut
no shut
end

802.1X port config example

interface GigabitEthernet X/XX
description 8021X_Enabled
switchport access vlan 66
switchport mode access
switchport voice vlan 90
qos trust cos
authentication event fail action authorize vlan 202
authentication event no-response action authorize vlan 202
authentication host-mode multi-host
authentication port-control auto
authentication periodic
auto qos voip trust
dot1x pae authenticator
dot1x timeout quiet-period 5
dot1x timeout server-timeout 10
dot1x max-reauth-req 1
storm-control broadcast level 20.00
storm-control action shutdown
tx-queue 3
   bandwidth percent 33
   priority high
   shape percent 33
spanning-tree portfast
spanning-tree bpduguard enable
service-policy output autoqos-voip-policy
shut
no shut
end

Configure a trunk
interface gigabitethernet x/xx
switchport trunk encapsulation dot1q
switchport mode trunk
description XXXXX
 switchport trunk native vlan 100
 switchport trunk allowed vlan 10,50,60,66,67,100,110,130
 qos trust cos
 auto qos voip trust
 tx-queue 3
   bandwidth percent 33
   priority high
   shape percent 33
 service-policy output autoqos-voip-policy

RESTART SWITCH REMOTELY
reload

CONFIGURE IP OF SWITCH

configure terminal
interface vlan XX
ip address 192.168.99.11 255.255.255.0
no shutdown
exit
ip default-gateway 192.168.99.1
end
copy running-config startup-config

CHANGE NAME OF CISCO SWITCH
hostname Corp-Training

configureVLAN

Conf t
Vlan #
State active
End
Write
Or copy run start

Add unifi node to controller

1. Start a ping in a cmd prompt window. This will help you know when controller is up or down.

2. Login into UNFI device using putty via SSH.  (default is ubnt/ubnt) but if device is already acquired, System will give it custom password:

a. log into controller gui.
b goto 'settings button' on the lower left side
c. goto DEVICE AUTHENTICATION
d. click on the the picture of the 'eye' to show the controller password.
e. note the user name that is assigned then you can ssh to the controller using the IP of the controller and the user/password shown on that page

3. From command prompt send the command:  This will reset the configuration of the node back to factory default.

syswrapper.sh restore-default

Controller will now reboot.

4. Once controller is available again, SSH back in.  the user/password will now be " ubnt/ubnt"

5. Send the following command: Alter the "ip-of-controller" to the ip of your systems controller

set-inform http://IPofCONTROLLER:8080/inform
(example: set-inform http://10.1.100.100:8080/inform)

6. The device will appear ready for "pending adoption" in the controller. Click Adopt.

7. Wait for the 'Adopting' status to appear on the UniFi controller, then issue the set-inform command again.

8. The device should now change to a 'Provisioning' status and then connect shortly thereafter.

If the adoption failed, check this blog for "Unifi Adoption Failed" procedure that might work for you.

Sunday, February 11, 2018

Using unshielded ethernet Cat5 Cat5e Cat6 wire as an XLR audio snake

This article will focus on un-shielded Ethernet cable to get THREE (3) analog audio channels vs the commonly advertised products providing four (4) channels on shielded Ethernet cable.
  • Cat5/6 Un-shielded Ethernet wire will allow 3 balanced "XLR" analog audio channels
  • Works with phantom power and works with ClearCom
  • Audio is clean, no buzzes, no hums, no distortion.  
  • Solid or stranded core (stranded less prone to breaking if coiled often)
  • 1000 foot XLR snake is possible.

What's the main differences between UN-SHIELDED and SHIELDED Ethernet cable for audio? 
  1. Shielded Ethernet has the same 4 pairs but with an additional wire allowing for 4 (four) channels.
  2. COST.  UN-shielded Ethernet is inexpensive cable found almost everywhere and is 2-4 times cheaper than its counterpart.
But we need the shield for audio quality right?

No. The shield (metal foil) found in some balanced mic cable only provides rejection enhancement for certain situations.  The way balanced audio provides clean signals over a wire results from the positive (in-phase) and negative (out-of-phase) balanced relationship of the analog signal as it travels together over the cable pairs.



UN-SHIELDED ETHERNET CABLE (two channels)
We can easily just connect an XLR pins on either end of the Ethernet wire and get 2 channels of audio.  XLR uses 3 wires for channel, and Ethernet has 8 wires, so that will easily get us 2 channels as shown in this diagram.

Solution A - Two balanced channels

XLR over Cat5 using standard wiring methodology (2 unused wires)

UN-SHIELDED ETHERNET CABLE (three channels)

The trick to maximize the number of audio channels on either Ethernet type cabling is sharing the ground connection with the other audio channels on the cable.

By using just 1 of the wires on the cable for the ground, and connecting it to the ground points for each channel, we free up an additional wire on the cable


The ground wires are both going to the same brown wire.  The Green wires are now unused.


Solution B - Three balanced channels by sharing the ground.

In this example each positive and negative wire is connected to orange, green or blue.  But now the ground points are on the same brown wire on either side of the Ethernet cable.  This is the trick to get the additional balanced audio channel!


Wiring Diagram

Here are some more detailed wiring diagrams.  In this example the brown/white stripe wire is used for common ground, the brown wire can either be ignored, or attached to the same points simultaneously as the brown/white wires.

Channel 1 blue pair 
Channel 2 Orange Pair 
Channel 3 Green Pair 
Ground Brown pair 


A variation is assigning one channel its own dedicated ground wire since we still have a brown wire going unused. Perhaps some channels are going to a different location, this might help to address that situation.  (Channel 1&2 goes to FOH, Channel 3 goes to a rented mobile production truck)

Implementation methods

Here are a few termination examples that could be used, but with an understanding of the wiring diagram, there are many possibilities that could be explored.

This example uses DB9 serial connectors.  





This example uses DB9 breakout boxes which don't require soldering.  (detailed implementation below)

Possible Applications
Send audio through preexisting Ethernet infrastructure allowing connections between locations (MUST bypass all Ethernet components like hubs or switches) allowing analog signals via the in house wires.  
Must not pass through any electronic equipment, direct patching between patch bay ports is ok.

In a situation that use this method all the Ethernet jacks were patched directly by IT staff.  Essentially a super long Ethernet wire cable, but not limited by the Ethernet length of 300 foot normal limitiation.  A 1000' or more long connection in many cases is achievable.

TOO LONG; DIDN'T READ

An efficient no soldering way to build pigtails using an RJ45 breakout box connected to the XLR connectors.  The one shown is a "female" adapter.
Use standard Ethernet cable with RJ45 ends to link each end of the snake.


In the diagram below, I show a possible wiring diagram that also takes into consideration the "split pair" wiring that a properly built RJ45 Ethernet cable needs to follow.
Connect the Positive, Negative and Ground wires from each XLR connector to the terminal adapter according to the diagram shown.
"Hey, why is channel 2 wires not seem to be in order in this picture?"
This means that the second pair although twisted together, needs to be connected to pins 3 & 6 at each end to ensure the positive and negative signals travel together and are not 'split'. (where the +/- signals travel on separate wires.  This will negatively impact the signal greatly if not followed!


Repeat the process for the other end.  NOTE how two of the XLR ground connections share the same connection point.  Sharing the ground allows for the 3rd connection and has no effect on the signal quality of either channel.

IMPORTANT!!!

A properly built RJ45 Ethernet cable uses pin groups of  
ORANGE PINS: 1 & 2
GREEN PINS: 3 & 6
BLUE PINS: 4 & 5
BROWN: PINS 7 & 8


So the seamingly 'all over the place' wiring in the above picture is required to be followed for this to work successfully.

If you connect the pigtails to a properly built ethernet cable, clean audio should now pass across the wire.